Valheim

Upload your cheat tables here (No requests)
Codcat
Novice Cheater
Novice Cheater
Posts: 15
Joined: Fri Mar 03, 2017 1:06 am
Reputation: 0

Re: Valheim

Post by Codcat »

Oddly after godmode has been turned on it will not unload the script properly on disabling, the X checkbox won't disappear and you cannot re-enable.

How to use this cheat table?
  1. Install Cheat Engine
  2. Double-click the .CT file in order to open it.
  3. Click the PC icon in Cheat Engine in order to select the game process.
  4. Keep the list.
  5. Activate the trainer options by checking boxes or setting values from 0 to 1

User avatar
Akira
Table Makers
Table Makers
Posts: 309
Joined: Fri May 24, 2019 2:04 am
Reputation: 207

Re: Valheim

Post by Akira »

ds891 wrote:
Tue Mar 30, 2021 9:47 am
Thanks for the 3.0 update, all the new features added have been awesome!

Just a bug to report though: I can't seem to steer the ship everytime I activate any of the ship related options, thus rendering them pretty useless :(
I think the "Sail Force" script is causing it, maybe try to use the "Force Wind" script instead, can be found in "WORLD RELATED" --> "Weather & Time".

ermahgerd
Noobzor
Noobzor
Posts: 8
Joined: Wed Apr 19, 2017 3:20 pm
Reputation: 0

Re: Valheim

Post by ermahgerd »

Codcat wrote:
Tue Mar 30, 2021 10:31 am
Oddly after godmode has been turned on it will not unload the script properly on disabling, the X checkbox won't disappear and you cannot re-enable.
same here. says that RESTORE_InGodMode added to the symbollist but not declared

User avatar
Akira
Table Makers
Table Makers
Posts: 309
Joined: Fri May 24, 2019 2:04 am
Reputation: 207

Re: Valheim

Post by Akira »

ermahgerd wrote:
Thu Apr 01, 2021 2:08 pm
Codcat wrote:
Tue Mar 30, 2021 10:31 am
Oddly after godmode has been turned on it will not unload the script properly on disabling, the X checkbox won't disappear and you cannot re-enable.
same here. says that RESTORE_InGodMode added to the symbollist but not declared
Now I have the same problem, not sure why bc it worked fine for me before and there wasn't another update..
Anyways I have fixed it and I'll upload the new version soon.

ermahgerd
Noobzor
Noobzor
Posts: 8
Joined: Wed Apr 19, 2017 3:20 pm
Reputation: 0

Re: Valheim

Post by ermahgerd »

Akira wrote:
Thu Apr 01, 2021 11:42 pm
ermahgerd wrote:
Thu Apr 01, 2021 2:08 pm
Codcat wrote:
Tue Mar 30, 2021 10:31 am
Oddly after godmode has been turned on it will not unload the script properly on disabling, the X checkbox won't disappear and you cannot re-enable.
same here. says that RESTORE_InGodMode added to the symbollist but not declared
Now I have the same problem, not sure why bc it worked fine for me before and there wasn't another update..
Anyways I have fixed it and I'll upload the new version soon.
oh. the same issue occurs with the stealth+god mode also. RESTORE_InGhostMode not declared. forgot to add

User avatar
Akira
Table Makers
Table Makers
Posts: 309
Joined: Fri May 24, 2019 2:04 am
Reputation: 207

Re: Valheim

Post by Akira »

Yeh, no idea wtf is going on, the last time I had tested the scripts everything worked fine and now , some days later, god & ghost mode are broken (maybe more?)..there wasn't even a game update..
Really strange but I'll upload a fixed version in some hours.

Here are the two fixed scripts if don't want to wait.
God Mode:

Code: Select all

define(address,Player:InGodMode+b)
define(bytes,0F B6 80 51 05 00 00)

[ENABLE]


assert(address,bytes)
alloc(newmem,$100,Player:InGodMode+b)
alloc(RESTORE_InGodMode,8)

label(code)
label(return)

newmem:
  mov [RESTORE_InGodMode],rax
  mov [rax+00000551],#1

code:
  movzx eax,byte ptr [rax+00000551]
  jmp return

address:
  jmp newmem
  nop 2
return:
registersymbol(RESTORE_InGodMode)

[DISABLE]
{$lua}
  writeInteger('[RESTORE_InGodMode]+551',0)
{$asm}
unregistersymbol(RESTORE_InGodMode)
dealloc(RESTORE_InGodMode,8)

address:
  db bytes
  // movzx eax,byte ptr [rax+00000551]

dealloc(newmem)
Stealth + God Mode:

Code: Select all

define(address,Player:InGhostMode+b)
define(bytes,0F B6 80 52 05 00 00)

[ENABLE]


assert(address,bytes)
alloc(newmem,$100,Player:InGhostMode+b)
alloc(RESTORE_InGhostMode,8)

label(code)
label(return)

newmem:
  mov [RESTORE_InGhostMode],rax
  mov [rax+00000552],#1

code:
  movzx eax,byte ptr [rax+00000552]
  jmp return

address:
  jmp newmem
  nop 2
return:
registersymbol(RESTORE_InGhostMode)

[DISABLE]
{$lua}
  writeInteger('[RESTORE_InGhostMode]+552',0)
{$asm}
unregistersymbol(RESTORE_InGhostMode)
dealloc(RESTORE_InGhostMode,8)

address:
  db bytes
  // movzx eax,byte ptr [rax+00000552]

dealloc(newmem)

aSwedishMagyar
Table Makers
Table Makers
Posts: 394
Joined: Mon Jul 06, 2020 3:19 am
Reputation: 455

Re: Valheim

Post by aSwedishMagyar »

Akira wrote:
Fri Apr 02, 2021 2:32 am

Here are the two fixed scripts if don't want to wait.
Those values are byte sized so writing an integer is going to overwrite the next 4 bytes as well which can mess things up for you, use writeBytes(address,00) instead.

Also, why not just grab the player base address in your enable and write the cVars using that? They keep their value so there is no need to hook their function here, it just makes it more difficult for you to update in the future.

scientits
What is cheating?
What is cheating?
Posts: 1
Joined: Thu Apr 08, 2021 4:05 pm
Reputation: 0

Re: Valheim

Post by scientits »

Akira wrote:
Thu Mar 25, 2021 3:15 pm
asofd wrote:
Thu Mar 25, 2021 3:08 am
hi is "Change Pickaxe Radius (Doesn't reset after deactivating)" not working for anyone else? the box doesn't even X on when I try to click on it
Yeh still didn't checked it but also I'm pretty sure that there's a information that it does not reset when deactivating.
The part where you can change the value got the original value in the name so you can manually reset it.
I am incredibly new to CTs, so bear with me. But when I poked around the script and information contained in the table, I could find no workaround to get it fixed. I had never been able to get it to activate, thus I don't believe I'm using the non-default radius, however I could be wrong. Is there a way to search for the string or hex or run another script to determine what the current value is?

(thanks for all the work you all put into these, they make sandboxing, building, terraforming a lot of fun)

User avatar
Akira
Table Makers
Table Makers
Posts: 309
Joined: Fri May 24, 2019 2:04 am
Reputation: 207

Re: Valheim

Post by Akira »

scientits wrote:
Thu Apr 08, 2021 4:17 pm
I am incredibly new to CTs, so bear with me. But when I poked around the script and information contained in the table, I could find no workaround to get it fixed. I had never been able to get it to activate, thus I don't believe I'm using the non-default radius, however I could be wrong. Is there a way to search for the string or hex or run another script to determine what the current value is?

(thanks for all the work you all put into these, they make sandboxing, building, terraforming a lot of fun)
Works "fine" on my end, it doesn't matter which value it got on your end, the address should be the same.
Normaly it should work as longs as you didn't changed any game files or you're using any kind mods.

Codcat
Novice Cheater
Novice Cheater
Posts: 15
Joined: Fri Mar 03, 2017 1:06 am
Reputation: 0

Re: Valheim

Post by Codcat »

None of the food scripts seem to work if you're using BepInEx/valheim plus... you can enable/disable them no problem but they have no effect.
I have the food section disabled in the valheim_plus.cfg so it shouldn't be clashing.

Anyone else experience this and have a work around or fix?

Edit: Actually nevermind, carry weight and probably others are also incompatible :-/

User avatar
Akira
Table Makers
Table Makers
Posts: 309
Joined: Fri May 24, 2019 2:04 am
Reputation: 207

Re: Valheim

Post by Akira »

Codcat wrote:
Fri Apr 09, 2021 8:26 am
None of the food scripts seem to work if you're using BepInEx/valheim plus... you can enable/disable them no problem but they have no effect.
I have the food section disabled in the valheim_plus.cfg so it shouldn't be clashing.

Anyone else experience this and have a work around or fix?

Edit: Actually nevermind, carry weight and probably others are also incompatible :-/
It is well known that mods can cause problems for the table.
I can't make a different table version for every single mod :wink:.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], Csimbi, Google [Bot], Google Adsense [Bot], Sakkix, Shrakend, Thelonius Bone, Ukuboy, unmog, WhiteNOiz, xduduhao, Zinos