Bug 7.1 CE version

Anything Cheat Engine related, bugs, suggestions, helping others, etc..
User avatar
xorps
Table Makers
Table Makers
Posts: 67
Joined: Sun Nov 05, 2017 11:39 am
Reputation: 44

Bug 7.1 CE version

Post by xorps »

Hi guys! Why doesn't it write zero normally :? On CE version 7.0 everything is normal writes
Picture! [Link] [Link]

User avatar
TheyCallMeTim13
Administration
Administration
Posts: 1480
Joined: Fri Mar 03, 2017 12:31 am
Reputation: 742

Re: Bug 7.1 CE version

Post by TheyCallMeTim13 »

Didn't notice it does that, because I tend to use a registry and XOR. which is kinda funny given your username, but it takes less bytes that way. Looks like you can just use XMM7 here, at least as a work around for now.

Code: Select all

//...
xorps xmm7,xmm7
//...
movss [rax+A0C],xmm7
//...

Eric
Hall of Famer
Hall of Famer
Posts: 123
Joined: Thu Mar 02, 2017 11:01 pm
Reputation: 54

Re: Bug 7.1 CE version

Post by Eric »

What CE version are you using? Where did you get it?
Check on help->check for new version

(The bug you have is from a RC or Beta version of 7.1)

If for some reason people are using an unsupported beta builds I recommend you add this code to your tables:

Code: Select all

if (getCEVersion()==7.1) and (getCheatEngineFileVersion()<1970329131948229) then
  showMessage('You are on an outdated CE build')
  closeCE()
end

User avatar
xorps
Table Makers
Table Makers
Posts: 67
Joined: Sun Nov 05, 2017 11:39 am
Reputation: 44

Re: Bug 7.1 CE version

Post by xorps »

TheyCallMeTim13 wrote:
Mon May 11, 2020 11:45 am
Didn't notice it does that, because I tend to use a registry and XOR. which is kinda funny given your username, but it takes less bytes that way. Looks like you can just use XMM7 here, at least as a work around for now.
You misunderstand me. CE writes invalid data :)
video test >
Spoiler

User avatar
xorps
Table Makers
Table Makers
Posts: 67
Joined: Sun Nov 05, 2017 11:39 am
Reputation: 44

Re: Bug 7.1 CE version

Post by xorps »

Eric wrote:
Mon May 11, 2020 11:55 am
What CE version are you using? Where did you get it?
-----
here I downloaded 7.1 [Link]
Picture > [Link] not a beta version

User avatar
mgr.inz.Player
Cheater
Cheater
Posts: 35
Joined: Fri Mar 03, 2017 8:41 am
Reputation: 38

Re: Bug 7.1 CE version

Post by mgr.inz.Player »

you have to actually test it with Lua script.

What you get when you execute this inside "Lua Engine" window?

Code: Select all

return getCheatEngineFileVersion()
Or check both binaries:

Code: Select all

return '32bit ',{getFileVersion(getCheatEngineDir()..'cheatengine-i386.exe')},
       '64bit ',{getFileVersion(getCheatEngineDir()..'cheatengine-x86_64.exe')}

User avatar
xorps
Table Makers
Table Makers
Posts: 67
Joined: Sun Nov 05, 2017 11:39 am
Reputation: 44

Re: Bug 7.1 CE version

Post by xorps »

Here guys is the complete installation :(
Spoiler
Released 04/26/2020

User avatar
mgr.inz.Player
Cheater
Cheater
Posts: 35
Joined: Fri Mar 03, 2017 8:41 am
Reputation: 38

Re: Bug 7.1 CE version

Post by mgr.inz.Player »

What happens when you use single line assembler and not AA script?

In memory viewer double click on any "add [rax],al" and type in:

Code: Select all

mov [rax+70],(float)1
and also try this:

Code: Select all

dd (float)1
and check if it sets bytes to 80 3F 00 00

User avatar
xorps
Table Makers
Table Makers
Posts: 67
Joined: Sun Nov 05, 2017 11:39 am
Reputation: 44

Re: Bug 7.1 CE version

Post by xorps »

mgr.inz.Player wrote:
Mon May 11, 2020 1:26 pm
and also try this:
--
Picture > [Link]

this happens in three games :mellow: х64

Eric
Hall of Famer
Hall of Famer
Posts: 123
Joined: Thu Mar 02, 2017 11:01 pm
Reputation: 54

Re: Bug 7.1 CE version

Post by Eric »

You're running a CE install from your desktop, but is that where the download went to ? (also something about kaspersky there)
Usually if you're downloading a file you've previously downloaded there should be a (1) , or (2) behind the name

run this lua code and tell us what happens

Code: Select all

if (getCEVersion()==7.1) and (getCheatEngineFileVersion()<1970329131948229) then
  showMessage('Update your CE (Redownload CE)')
  closeCE()
end

User avatar
xorps
Table Makers
Table Makers
Posts: 67
Joined: Sun Nov 05, 2017 11:39 am
Reputation: 44

Re: Bug 7.1 CE version

Post by xorps »

Eric wrote:
Mon May 11, 2020 1:48 pm
run this lua code and tell us what happens

I have a recent CE version (04/26/2020). I had run lua script posted above andd it have no effect because of my CE version is up to date. And I have no idea what I have supposed to do now. :(
So I will probably be on version 7.0 :(

User avatar
mgr.inz.Player
Cheater
Cheater
Posts: 35
Joined: Fri Mar 03, 2017 8:41 am
Reputation: 38

Re: Bug 7.1 CE version

Post by mgr.inz.Player »

Does it happen when you use a single-line assembler?
Image

User avatar
GreenHouse
GreenHouse!
GreenHouse!
Posts: 560
Joined: Fri Oct 12, 2018 10:25 pm
Reputation: 419

Re: Bug 7.1 CE version

Post by GreenHouse »

Did you restart settings when installing version 7.1? I had the same problem when using version 7.1 RC 2.3. But when I installed the new version and restarted settings, it did fix both versions, even RC 2.3.

Eric
Hall of Famer
Hall of Famer
Posts: 123
Joined: Thu Mar 02, 2017 11:01 pm
Reputation: 54

Re: Bug 7.1 CE version

Post by Eric »

Try this code then:

Code: Select all

if (getCEVersion()==7.1) and (getCheatEngineFileVersion()<1970329131948229) then
  showMessage('Update your CE (Redownload CE)')
  closeCE()
else
  local a,b=getCheatEngineFileVersion()
  print(b.build)
end
and post the results here

Also, you state you have 'recent CE version (04/26/2020)' but that is just the message the update server tells you, which is wrong by the way , it is in fact a different date., Check the codesigning date of the certificate of the CE exe

User avatar
xorps
Table Makers
Table Makers
Posts: 67
Joined: Sun Nov 05, 2017 11:39 am
Reputation: 44

Re: Bug 7.1 CE version

Post by xorps »

Eric wrote:
Mon May 11, 2020 6:39 pm
and post the results here
1) Settings were reset after installation in the video above
2) Picture [Link]
3) Picture [Link]

Post Reply

Who is online

Users browsing this forum: No registered users