Cannot assign a Value to a memory record

Anything Cheat Engine related, bugs, suggestions, helping others, etc..
Post Reply
S1N74X
Noobzor
Noobzor
Posts: 12
Joined: Wed Sep 15, 2021 4:25 pm
Reputation: 0

Cannot assign a Value to a memory record

Post by S1N74X »

Hi,

noob question maybe but is it a bug or am i missing something ?

mr = al.createMemoryRecord() --self explanory
mr.setAddress(DEADBEEF) --self explanory
mr.Description = "something" --self explanory
mr.Type = 4 --for float Value
mr.Value = 10 <<------- I would expect the value to be assigned here
But the Result is ?? instead
Any suggestions or tips ?

Thanks for any usefull help.

Eric
Hall of Famer
Hall of Famer
Posts: 146
Joined: Thu Mar 02, 2017 11:01 pm
Reputation: 77

Re: Cannot assign a Value to a memory record

Post by Eric »

is the address correct ?

S1N74X
Noobzor
Noobzor
Posts: 12
Joined: Wed Sep 15, 2021 4:25 pm
Reputation: 0

Re: Cannot assign a Value to a memory record

Post by S1N74X »

Eric wrote:
Thu Nov 25, 2021 5:33 pm
is the address correct ?
Its not a "real" Address. Its a created one.
I felt that this would be possible.

User avatar
LeFiXER
Expert Cheater
Expert Cheater
Posts: 256
Joined: Wed Mar 24, 2021 9:35 am
Reputation: 88

Re: Cannot assign a Value to a memory record

Post by LeFiXER »

S1N74X wrote:
Fri Nov 26, 2021 1:24 pm
Its not a "real" Address. Its a created one.
I felt that this would be possible.
The address has to exist to be able to write a value to it.

S1N74X
Noobzor
Noobzor
Posts: 12
Joined: Wed Sep 15, 2021 4:25 pm
Reputation: 0

Re: Cannot assign a Value to a memory record

Post by S1N74X »

LeFiXER wrote:
Fri Nov 26, 2021 1:39 pm
S1N74X wrote:
Fri Nov 26, 2021 1:24 pm
Its not a "real" Address. Its a created one.
I felt that this would be possible.
The address has to exist to be able to write a value to it.
Ok. Is it possible to create a real Address in LUA or get the Address of a LUA Variable ?
Creating a symbol wont help
ASM :
alloc(bla,8),
registersymbol(bla)
bla :
dq (float)123.456

"bla" will hold the Value 123.456 but no Address

User avatar
LeFiXER
Expert Cheater
Expert Cheater
Posts: 256
Joined: Wed Mar 24, 2021 9:35 am
Reputation: 88

Re: Cannot assign a Value to a memory record

Post by LeFiXER »

S1N74X wrote:
Fri Nov 26, 2021 4:16 pm
Ok. Is it possible to create a real Address in LUA or get the Address of a LUA Variable ?
Creating a symbol wont help
ASM :
alloc(bla,8),
registersymbol(bla)
bla :
dq (float)123.456

"bla" will hold the Value 123.456 but no Address
There are some functions you can use:

Code: Select all

allocateMemory(size, BaseAddress OPTIONAL, Protection OPTIONAL): Allocates some memory into the target process
deAlloc(address, size OPTIONAL): Frees allocated memory
Note: case sensitive

It's worth reading through the celua.txt file [Link].

A symbol is a reference to the address with a more memorable identifier than just a bunch of alphanumeric characters.

"bla" is the reference to the address, "[bla]" is the value held at the address "bla". You could use Lua to get the address after the symbol has been registered:

Code: Select all

local myaddress = getAddressSafe('bla')
if myaddress ~= nil then
  print(string.format("%X", myaddress))
end

S1N74X
Noobzor
Noobzor
Posts: 12
Joined: Wed Sep 15, 2021 4:25 pm
Reputation: 0

Re: Cannot assign a Value to a memory record

Post by S1N74X »

LeFiXER wrote:
Fri Nov 26, 2021 4:54 pm
S1N74X wrote:
Fri Nov 26, 2021 4:16 pm
Ok. Is it possible to create a real Address in LUA or get the Address of a LUA Variable ?
Creating a symbol wont help
ASM :
alloc(bla,8),
registersymbol(bla)
bla :
dq (float)123.456

"bla" will hold the Value 123.456 but no Address
>> A symbol is a :!: reference to the address :!: with a more memorable identifier than just a bunch of alphanumeric characters <<
>> :!: 'bla" :!: is the reference to the address , :!: "[bla]" :!: is the value held at the address "bla" <<
Thank you very much.
That fixed my Problem :)
+1

User avatar
LeFiXER
Expert Cheater
Expert Cheater
Posts: 256
Joined: Wed Mar 24, 2021 9:35 am
Reputation: 88

Re: Cannot assign a Value to a memory record

Post by LeFiXER »

S1N74X wrote:
Mon Nov 29, 2021 12:24 pm
Thank you very much.
That fixed my Problem :)
+1
You're welcome :). Glad I could help.

Post Reply

Who is online

Users browsing this forum: No registered users