Subterrain

STN

Pleb
Staff member
Administrator
Mar 2, 2017
3,104
102
63
#1
Simple table for Subterrain, may or may not work. Game generates code at runtime so table has a high chance of not working / detecting the wrong code / crashing.

Usage info:
Scripts with "To Activate: XXX" can only be activated (put an "X" into the box) after doing action XXX.
Scripts with "To Update: XXX" will only update their effect after doing action XXX.
Addresses with "XXX?" will enable the script effect XXX when 1 is put into the Value.

In general:
A. Do action YYY.
B. Activate (put an X) the "Initialization (Activate This First)" script.
C. Activate (put an X) the "Base Address Scan (To Activate: YYY, To Update: ZZZ)" script.
D. Enable (put a 1) the desired effect. Example: "Set Health to Max?" address.
E. Do action ZZZ.


V1000
1. Tested game version V1.0.0.7. May work on other versions.

2. GameStats.
"HP Set to Max?" sets HP to max
"Status Set to Optimal?" sets Hunger, Thirst etc to either 0 or max.
"Stats Set to Massive?" sets Mobility, Nightvision, Perception and Strength to massive.

3. InvCtrl.
"Max Weight Set to Massive?" sets Mas Weight to massive.

4. ItemContainer.
"Item Quantity Set to Max?" sets Item quantity to max.
"Item Durability Set to Max?" sets Item Durability to max.
"Power Packs Set to Max?" sets Power Packs power to max.

5. MapPowerManager.
"Capacity Set to Increase to 40000?" increases Generator Capacity to 40000.

Made by: Shinkansen
 

Attachments

Roland117

What is cheating?
May 8, 2017
2
0
1
#2
I would like to request fast crafting option, like what was in the table made by panraven. I wanted to request this on the original site, but single player cheat request seems to be locked down :/
 
Sep 6, 2017
5
0
1
#3
hi..is it possible to update the table..im currently at the latest version of 1.171
tried to search for life..but can't find it..
 
Sep 6, 2017
5
0
1
#4
try to find couple of the pointers..when i load for the first time on the first save..its looks fine..when i try to load the game once again ( when i still in game /without quiting the game )..all the pointers are scrambles..dunno why..it's looks like it can only use once , when at start..
 

TillMurray

What is cheating?
Apr 9, 2018
1
0
1
#6
How do I even find static addresses for this game? I searched by all, tried unknown values, increased/decreased values, all to no avail. Anyone have any ideas?
Edit: nvm, Scan Settings had ALL types to include only 2 and 4 bytes only. Checking the rest allowed me to find the static addresses.
 

TZP

What is cheating?
Mar 14, 2018
2
0
1
#7
With the addition to the newest humble bundle, this table needs an update.
I'll try but I am by no means capable of making tables.
 

McCheesemaker

What is cheating?
Apr 17, 2018
2
0
1
#9
I made this back in August as AOB so, in theory, it should still work.
Most of it is just swapping `fstp dword ptr [address]` with `fstp st(0)` to disable stuff.

Due to the way the game loads code, you generally have to do something to cause the effect before you can disable it.
It's been months since I've played but IIRC only the marked one will cause a crash if you don't deactivate before loading a save file.
Also, if the script won't activate, chances are the game hasn't loaded that code for AOB to find. Do something that would trigger the effect, then try the script again.
IIRC once it's loaded it stays that way, so you can hurt yourself to trigger the armor durability thing, activate script, then reload.

I used the GoG version to make this. Not sure of the game version, but file timestamp indicates I made this Aug 20 2017.

Scripts:
Code:
No durability decrease (weapons)
No durability decrease (armor) [Before Activate: Take Damage]
No quick slock decrease [Before Activate: Throw Grenade]
No used item decrease [DEACTIVATE BEFORE LOAD, Use Item, Then Activate]
No reactor module decay
No durability decrease (reactor weapons)
No fatigue
No thirst
No o2 drain
No thermal drain
No weapon heatup
No flashlight drain
Weapons use no energy
PS: Attaching my notes file as it has copy+paste of the assembly where I found the code to modify. Much easier to use as a starting point since none of the script have documentation.
 

Attachments

Last edited:
Top Bottom